SolutionCottage.com
Posted  31 Oct 2008 - 08:36:34

Category: Windows


(HRESULT: 0x80070057 (E_INVALIDARG)) on debug

Issue:
When trying to debug an ASP.net website in Visual Studio you get the following error message:

Could not load file or assembly 'your project' or one of its dependencies. The parameter is incorrect. (Exception from HRESULT: 0x80070057 (E_INVALIDARG))

Solution:
Clear out the temporary framework files for your project in:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\

Update:

For Windows 7, the path is:
C:\Users\[username]\AppData\Local\Temp\Temporary ASP.NET Files\

For 64 bit systems with 'Framework' in the path the full path is:
C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files\



Marked as helpful by 349 users




127 comments:

8/28/2014 7:14:24 AM  Nippon Aman  wrote:

This is helpfull, I have no word to thank.


8/22/2014 5:34:50 AM  Maninder  wrote:

thanxx man its really helpfull


8/14/2014 8:32:37 AM  Sheethal  wrote:

Thank you very much ..... now it is working


7/1/2014 8:14:39 AM  deadAlex  wrote:

thx))


6/2/2014 8:26:58 AM  Muhammad Abubakar  wrote:

Good it's work man


4/25/2014 10:38:13 AM  korea  wrote:

thank you: ?????.!!


4/16/2014 7:52:48 PM  Brett W.  wrote:

Thank you fine sir. Had been searching for hours to a solution that works


4/7/2014 8:32:05 AM  Mukesh Dutt  wrote:

Thanks for solution.


4/7/2014 8:31:58 AM  Mukesh Dutt  wrote:

Thanks for solution.


4/7/2014 8:17:59 AM  Amiya  wrote:

Thanx a ton..It helped me..


2/28/2014 11:43:03 AM  Santhosh  wrote:

Try


1/13/2014 8:18:30 AM  hr2101711@gmail.com  wrote:

Hi I am using visual studio 4.0 i have cleared the temp. files but then also it is showing the same error plz help


11/5/2013 8:12:30 AM  Murali  wrote:

Ya this solution really useful for me... i got this error like could not find path......i was cleared that temp files....now working correctly.....


10/19/2013 5:37:21 AM  JJR70  wrote:

I was getting this error with WSUS on Server 2008 after Windows Updates. Your fix worked perfectly...THANK YOU!


10/2/2013 5:07:57 AM  Jahan  wrote:

Absolutelty Work 4 me!!!! Thanks.....


9/4/2013 7:53:29 PM  Ilysamo  wrote:

Use this: iisreset /stop DEL /Q /S /F %tmp% DEL /Q /S /F "C:\Windows\Microsoft.NET\Framework64\v2.0.50727\Temporary ASP.NET Files" DEL /Q /S /F "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files" DEL /Q /S /F "C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files" DEL /Q /S /F "C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files" DEL /Q /S /F "C:\Windows\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files" iisreset /start


7/23/2013 4:24:59 PM  eger[p  wrote:

[p[er


7/23/2013 2:55:46 PM  Victor  wrote:

Excelent!!! Greetings from Mexico


7/17/2013 8:40:15 AM  TP  wrote:

Thanks, but for me deleting temporary files didn't help either. I have to use the "start with a copy of another report" work-around.


6/21/2013 8:15:27 AM  faheem gul  wrote:

i have still facing the same problem after deleting Temporary files.


6/12/2013 7:43:31 AM  kalpana  wrote:

Thank you so much


5/30/2013 7:00:53 PM  Elis  wrote:

Very tks!


5/15/2013 3:24:43 PM  Chintan Gajera  wrote:

I Have No FOlder Name Temporary ASP.NET Files\


5/15/2013 11:17:12 AM  Madhuri  wrote:

This is really very helpful.


4/30/2013 1:13:03 PM  Simone  wrote:

tank's! very good solution Simone (IT)


4/23/2013 1:36:57 PM  Sandeep  wrote:

Thanks a lot


4/12/2013 11:21:08 AM  sreekanth  wrote:

work fine


4/10/2013 1:16:33 PM  Praveen  wrote:

For me problem was resolved Thanks...........


4/5/2013 11:58:36 AM  hariom  wrote:

thank you very much for the post but still it doesnt work i have cleared all the temp files but still it shows the same error message


4/4/2013 2:41:27 PM  samruddhi  wrote:

thank you so much.


3/14/2013 1:35:50 PM  Kenneth Davis  wrote:

I think this did it for me as well. Very much appreciated!!!


3/14/2013 11:49:08 AM  Random  wrote:

Thank you so much!!! It solved my problem. I had been wasting so much of time trying to fix this issue!


2/27/2013 6:15:34 PM  David  wrote:

Thanks for the info. It was very usefull for me.


2/22/2013 1:33:17 PM  hussien.shahata@gmail.com  wrote:

Thanks a lot its OK


2/13/2013 11:43:50 PM  not working  wrote:

not working in Windows 7 VS2010


1/18/2013 8:50:40 PM  Evandro  wrote:

Thank you!!!


Website: http://www.sqlserverdicas.com

1/15/2013 4:03:44 PM  amit  wrote:

awesome


1/9/2013 9:31:18 PM  palestine  wrote:

game


1/9/2013 9:31:12 PM  palestine  wrote:

game


1/9/2013 2:14:21 PM  Ganesh Magar  wrote:

well done. thanks.


1/6/2013 9:33:38 AM  Mc  wrote:

Thank you!!!


10/25/2012 4:43:13 AM  kibria  wrote:

Thanks a lot.


10/4/2012 10:24:55 AM  ludovic  wrote:

thanks a lot !


8/31/2012 7:10:13 AM  Sangeetha  wrote:

Thanks a lot, i was searching for the solution with many peoples/sites but i didnt get rite answer. Very helpful.Best wishes :)


8/17/2012 5:49:29 PM  m1cmdrpitch  wrote:

Many sites just mention: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ But for me this is the spot (as mentioned above) to resolve my problem C:\Users\[username]\AppData\Local\Temp\Temporary ASP.NET Files\


8/16/2012 12:14:25 PM  sebichondo  wrote:

Great solution


7/28/2012 3:14:23 AM  dangquest  wrote:

Thank you so much. Thank you !


7/18/2012 1:23:50 PM  Kevin  wrote:

Thank You so so much :)


7/17/2012 4:45:49 AM  Jitendra  wrote:

It works...i was literly blowing my mind off ...Thanks


7/7/2012 12:13:20 PM  sathiya  wrote:

Great Solution


7/6/2012 1:01:16 PM  Nadir jahan  wrote:

thanks it is very helpful.now my project working


6/29/2012 9:09:02 PM  Daniel  wrote:

Sincerely...I did the procedure, but I wasn't believing that this solution would work. But it works!!


6/1/2012 2:41:03 PM  Tony  wrote:

You're the boss ! I was running out of my mind trying to figure out how to fix it. Until I get to You page~;) Thanks !


5/23/2012 5:15:42 AM  wwlwwl.dec@gmail.com  wrote:

what do you mean by update? I already clear out.


5/23/2012 5:15:41 AM  wwlwwl.dec@gmail.com  wrote:

what do you mean by update? I already clear out.


5/18/2012 8:17:29 PM  BFPLima  wrote:

Excelent!!! Thank you!


5/18/2012 5:40:39 AM  Hek  wrote:

Thank you!!


4/20/2012 6:10:44 PM  Jay  wrote:

IT WORKED!!! THANKS A LOT!!!!


4/12/2012 1:13:03 PM  Rignesh  wrote:

Thanks man... it helped..


4/5/2012 8:32:25 AM  Ronil  wrote:

this helped. well done. thanks.


3/23/2012 2:47:08 PM  poet  wrote:

thanks Mikael. i like your site, keep it up!


3/23/2012 2:35:27 PM  mohammad  wrote:

hi thanks so much for your help


Website: www.nvzha.com

3/20/2012 2:22:13 PM  shekar  wrote:

super thambi...


3/19/2012 3:35:39 PM  Satheeshkumar  wrote:

You saved my life..Thanks pal.


3/13/2012 7:30:55 AM  Rohan  wrote:

Thanks Dude :)


2/26/2012 6:46:43 PM  umar.bcsf08@gmail.com  wrote:

it was a very good resource.thanks.


1/24/2012 11:27:51 PM  Tom Strange  wrote:

The power went out and our emergency backup didn't kick in yesterday. My computer went down. I did not try to use debug until today and got this error. This was a tough one. I could not have done it without you. THANKS!


1/19/2012 4:21:40 PM  @JoeMtz88  wrote:

It worked, thanks a lot


1/16/2012 7:48:05 AM  Madhu  wrote:

thanks , it really helps lot ..


1/9/2012 5:01:36 PM  Waqas Ahmed Hijazi  wrote:

That helped me a lot, thanks for your sharing. I have searched it out for long time. But only you post helped me. Thanks


1/3/2012 4:21:14 PM  Tito  wrote:

Thanks men, it really works


12/19/2011 8:20:25 AM  Ganesh Magar  wrote:

Thanks,it really Helpful


12/8/2011 3:33:51 PM  Rohan  wrote:

Thanx Buddy... Great Solution... really helpful post


11/29/2011 5:56:14 PM  narendras@chetu.com  wrote:

thanks for this solutions


11/21/2011 11:39:34 PM  douglas  wrote:

just delete your bin project directory dll


11/16/2011 7:05:54 AM  Irvin  wrote:

Thank you very much for this solution you have saved my life, thanks a lot


10/17/2011 8:08:56 PM  Aldo  wrote:

Thank You so much! Great Work


10/15/2011 7:04:25 AM  Rahul Shakya  wrote:

Gr8 work


10/14/2011 6:22:22 PM  ehab  wrote:

dgdf


10/14/2011 6:22:19 PM  ehab  wrote:

dgdf


10/5/2011 6:04:36 AM  Larron  wrote:

Thanks. Just ran into an issue with an Exchange 2010 Server and Autodiscover. I dumped the .net folder and all is well. Every other thing i tried failed. Nice to have a two second fix...Would not have found this out without your post.


9/27/2011 12:45:45 PM  Rahul Ranajn  wrote:

THanks dude...Got the right way..was getting frustated otherwise..


9/20/2011 10:40:13 PM  zdujonis  wrote:

tnx!!!!!!!!!!!!!!!!


9/16/2011 3:04:29 PM  Tiffany Fresh  wrote:

Stupendous, result. It recovered bunches of time. I was passing through regretful day and was practically getting distraught. Thank's a parcel man. I am going to write this down on my [url=http://www.trustedessays.net/]essay[/url].


9/16/2011 3:03:27 PM  Rachelle Lat  wrote:

Stupendous, result. It recovered bunches of time. I was passing through regretful day and was practically getting distraught. Thank's a parcel man. I am going to write this down on my <a href="http://www.trustedessays.net/">essay</a>.


9/6/2011 7:58:34 AM  Ganesh  wrote:

Thanks,it realy helpful...


8/30/2011 1:01:15 PM  Raji  wrote:

Good Job!


7/27/2011 11:41:33 AM  Murtaza Imran Saeed  wrote:

Thank Keep it up


7/27/2011 8:52:51 AM  devindia  wrote:

Thanx brother ..... really a great help


7/26/2011 11:44:19 AM  yrandhir@hotmail.com  wrote:

Great, solution. It saved lots of time. I was passing through bad day and was almost getting mad. Thank's a lot man.


7/19/2011 12:41:48 PM  biju menon  wrote:

it is very helpfull


7/15/2011 9:10:06 AM  mdj  wrote:

thanx dude!


6/29/2011 9:29:24 PM  Ricardo  wrote:

gracias me ayudo mas que la concha...


6/29/2011 7:42:50 PM  anees_azam@hotmail.com  wrote:

Your provided data is very help full for under practice developer. Today it save my time so thanks a lot.


5/20/2011 2:40:41 PM  Cluggas  wrote:

How Random. That is fricken' genius


4/28/2011 7:21:50 PM  krishan  wrote:

good...lot of thanks


4/19/2011 2:58:39 PM  krunal Patni  wrote:

Thanks for your wonderful solution. Keep up the good work !!!!!!!!!!!


3/7/2011 10:41:39 PM  Joris  wrote:

Thanks a lot, after 2 hours of frustration I found your post and my problem is solved!!


3/3/2011 9:34:26 PM  Martín Fernández  wrote:

Thank you!!!!!!!!!!!!! Hours and hours wasting time trying to understund why the error!!!! You save my month!! Martín - from Uruguay


3/2/2011 11:25:58 AM  Nitya  wrote:

thanks its really helpful..


1/31/2011 10:37:00 AM  entro  wrote:

on windows 7 64bit, i started by deleting the framework64 section and the problem did not go away. I then resumed on deleting all the temporary asp.net files from every folder and that fixed the issue. Thank you.


1/31/2011 2:11:44 AM  James Summerton  wrote:

Thanks for posting this. It solved my little problem.


1/12/2011 2:44:47 PM  xxx@xx.com  wrote:

Maestro... !! Thanks So Much...!!!


12/14/2010 6:10:03 PM  Ferran  wrote:

Excellent!!, This kind of errors drive me crazy... thanks Maestro!


10/4/2010 12:08:09 PM  santosh  wrote:

hi this helped alot, thanks:-)


9/24/2010 5:51:23 PM  Joel Dahlin  wrote:

Thank you so much for including the Win7 path.


9/21/2010 12:45:12 PM  jojo  wrote:

It tryed this but it oes not work on windows 7 with VS 2010


8/31/2010 8:16:40 AM  Utham  wrote:

This is very helpful...


8/13/2010 1:59:10 PM  Geekglad  wrote:

The solution saved loads of stress, since I had the issue twice. Awesome Tip and solution!!!!


8/5/2010 10:34:30 AM  sandy  wrote:

awesome...I am proudwa of u...


7/20/2010 1:28:05 PM  Aleksandar  wrote:

This works. Thanks


7/14/2010 8:31:10 PM  Seetha  wrote:

Thank you very much, very very helpful. Was going crazy when solution just would not build suddenly on my machine.


5/26/2010 6:35:39 AM  hotdog  wrote:

Most helpful!!! Thanks.


4/27/2010 6:10:52 PM  Varun  wrote:

Really Helpful for Win7 Users. Thanks


4/27/2010 10:00:16 AM  Yassir yahaya  wrote:

Thanks alot .... U Re the Man...U ve Saved me alot of distress


4/20/2010 4:20:32 PM  Numan  wrote:

It really helped


4/14/2010 6:03:41 AM  Andrew  wrote:

That has fixed it. Thanks


3/4/2010 4:37:30 AM  George Mauer  wrote:

Any idea if this is not an ASP.NET proeject?


2/10/2010 11:25:31 PM  Michael  wrote:

Thank you so much!


2/2/2010 2:29:20 PM  Rafael  wrote:

Thanks, helped me!!


2/1/2010 12:46:37 AM  Jeff  wrote:

TY!


1/16/2010 5:57:32 PM  Glib  wrote:

*bow* My humble thanks. You just saved me some major debugging time.


1/8/2010 11:23:18 PM  Kevin  wrote:

So know this post is old, but if you have that issue running Windows 7, then you will find the Temp ASP.NET Files directory under C:\Users\<user>\AppData\Local\Temp\Temporary ASP.NET Files Cleared that directory and all is better. VS 2008 started doing that to me the other day after my computer crashed. Everything ran I just kept getting the warning in VS 2008 about one of my referenced assemblies. I could publish and build without issues and the web app ran. Clearing the temp directory above fixed it on Windows 7. Thanks!


12/2/2009 11:51:08 PM  Ozgur  wrote:

Michael D you saved me... big time. thanks!! for 64=bit comment!


11/28/2009 2:37:07 AM  MichelD  wrote:

And if you're working on a 64 bits system, replace "Framework" in the above path with "Framework64".


8/21/2009 4:56:05 PM  VS User  wrote:

Exactly what I needed. Thank you for sharing.


6/25/2009 5:54:56 PM  Donald  wrote:

Wow ... I have been pulling my hair out this morning trying to get my solution to build. This was the answer! Thank you so much!!









© SolutionCottage 2008-2011 8/29/2014 4:12:25 AM